?

Log in

No account? Create an account
Zaurus upgrade -- again - Alex Belits
abelits
abelits
Zaurus upgrade -- again

Nine months ago I have upgraded my Zaurus last time, and had a mixed impression about it. Now I have found that a new OpenZaurus 3.5.3 is released, and decided to check if it is a noticeable improvement.

It is. In fact, if it wasn't for some stupid problems, it would be great, however as usual for OpenZaurus, every release has some annoying problems. This time those problems were:

  1. Truly atrocious startup scripts.
  2. fsck not called when mounting ramdisk or SD/MMC card with ext2 filesystem.
  3. ext3 still isn't supported by the provided kernel.
  4. GUI package manager still sometimes crashing for no reason.
  5. Serial port stil running getty by default.
  6. Crashing on suspending when suspend is called by pressing a button, and for some reason doing the same for "right arrow" held down for a few seconds.
  7. By default, home directory is sitting on builtin ROM, and not in RAM or a card.
  8. Konqueror package has dependency on some snapshot version of libqte2 that is not present in the distribution, however works fine with one supplied.
  9. gpsd is missing.
  10. For some reason portmap is enabled.

Everything else that I didn't like about the old version, was fixed. CF cards work without any glitches, supplied media player plays music without any tweaking, gpsd from 3.5.2 works just fine (except that it came with a wrong startup script), zroadmap is now included in the distribution, and is a 1.0.8 version, a noticeable improvement compared to 1.0.1 that I have used before. Everything is compiled with the same version of libraries, so after fixing the scripts, moving Opie to SD card and root's home to a ram disk, I have got something as reliable as the original Sharp ROM, and as useful as "bleeding edge" setup that I had to piece together before.

I should make patches and send them back to the developers.

Tags: , ,

3 comments or Leave a comment
Comments
j_b From: j_b Date: April 17th, 2005 05:41 pm (UTC) (Link)
Have you submitted bug / feature requests on these?
abelits From: abelits Date: April 17th, 2005 11:41 pm (UTC) (Link)
I have just installed it -- I certainly will, right after I will make a patch for startup scripts that caused most of the problems.
sprainedsoul From: sprainedsoul Date: April 26th, 2005 01:31 pm (UTC) (Link)

zaurus

I just wish PDAxRoms would support the 6000L. I see no reason why it could not run X/gtk apps
3 comments or Leave a comment